use strict;
my $str = '#foo #foo #foo';
my $regex = qr/#foo(?=\s|$)/p;
my $subst = '#bar';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";