using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#foo(?=\s|$)";
string substitution = @"#bar";
string input = @"#foo #foo #foo";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}