#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!0)\d{1,4}|0|\.\d{1,3})($|\.$|\.\d{1,3}$)"
Local $sString = "1234.123" & @CRLF & _
"321.1234" & @CRLF & _
"12.123" & @CRLF & _
"1.123" & @CRLF & _
"1.000" & @CRLF & _
"a.123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")