import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!0)\\d{1,4}|0|\\.\\d{1,3})($|\\.$|\\.\\d{1,3}$)";
final String string = "1234.123\n"
+ "321.1234\n"
+ "12.123\n"
+ "1.123\n"
+ "1.000\n"
+ "a.123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}