using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!0)\d{1,4}|0|\.\d{1,3})($|\.$|\.\d{1,3}$)";
string input = @"1234.123
321.1234
12.123
1.123
1.000
a.123
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}