re = /^((?!0)\d{1,4}|0|\.\d{1,3})($|\.$|\.\d{1,3}$)/m
str = '1234.123
321.1234
12.123
1.123
1.000
a.123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end