#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[([^\[\]]++|(?R))*+\]"
Local $sString = "<p>A body of text with a media module element embedded.<p>[[{"fid":"1234","view_mode":"full","type":"media","attributes":{"height":281,"width":224,"style":"float: right;","alt":"image caption","title":"Image name","class":"media-element file-full"}}]]<p>Proin faucibus ullamcorper sapien. In viverra faucibus imperdiet. Proin a libero vulputate, imperdiet turpis eu, congue arcu. Quisque id nullam.</p>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")