package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[([^\[\]]++|(?R))*+\]`)
var str = `<p>A body of text with a media module element embedded.<p>[[{"fid":"1234","view_mode":"full","type":"media","attributes":{"height":281,"width":224,"style":"float: right;","alt":"image caption","title":"Image name","class":"media-element file-full"}}]]<p>Proin faucibus ullamcorper sapien. In viverra faucibus imperdiet. Proin a libero vulputate, imperdiet turpis eu, congue arcu. Quisque id nullam.</p>
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}