use strict;
my $str = '<p>A body of text with a media module element embedded.<p>[[{"fid":"1234","view_mode":"full","type":"media","attributes":{"height":281,"width":224,"style":"float: right;","alt":"image caption","title":"Image name","class":"media-element file-full"}}]]<p>Proin faucibus ullamcorper sapien. In viverra faucibus imperdiet. Proin a libero vulputate, imperdiet turpis eu, congue arcu. Quisque id nullam.</p>
';
my $regex = qr/\[([^\[\]]++|(?R))*+\]/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}