using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([^\[\]]++|(?R))*+\]";
string input = @"<p>A body of text with a media module element embedded.<p>[[{""fid"":""1234"",""view_mode"":""full"",""type"":""media"",""attributes"":{""height"":281,""width"":224,""style"":""float: right;"",""alt"":""image caption"",""title"":""Image name"",""class"":""media-element file-full""}}]]<p>Proin faucibus ullamcorper sapien. In viverra faucibus imperdiet. Proin a libero vulputate, imperdiet turpis eu, congue arcu. Quisque id nullam.</p>
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}