using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(h\d+|a)\b.+?</\1>(*SKIP)(*F)|\b(СЛОВО)\b";
string input = @"<h1>
#\b(СЛОВО)\b#isUu
</h1>
#\b(СЛОВО)\b#isUu
<a>
#\b(СЛОВО)\b#isUu
</a>
#\b(СЛОВО)\b#isUu";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}