$re = '~<(h\d+|a)\b.+?</\1>(*SKIP)(*F)|\b(СЛОВО)\b~uis';
$str = '<h1>
#\\b(СЛОВО)\\b#isUu
</h1>
#\\b(СЛОВО)\\b#isUu
<a>
#\\b(СЛОВО)\\b#isUu
</a>
#\\b(СЛОВО)\\b#isUu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);