re = /<(h\d+|a)\b.+?<\/\1>(*SKIP)(*F)|\b(СЛОВО)\b/i
str = '<h1>
#\\b(СЛОВО)\\b#isUu
</h1>
#\\b(СЛОВО)\\b#isUu
<a>
#\\b(СЛОВО)\\b#isUu
</a>
#\\b(СЛОВО)\\b#isUu'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end