const regex = new RegExp('<(h\\d+|a)\\b.+?</\\1>(*SKIP)(*F)|\\b(СЛОВО)\\b', 'guis')
const str = `<h1>
#\\b(СЛОВО)\\b#isUu
</h1>
#\\b(СЛОВО)\\b#isUu
<a>
#\\b(СЛОВО)\\b#isUu
</a>
#\\b(СЛОВО)\\b#isUu`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}