import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(h\\d+|a)\\b.+?</\\1>(*SKIP)(*F)|\\b(СЛОВО)\\b";
final String string = "<h1>\n"
+ "#\\b(СЛОВО)\\b#isUu\n"
+ "</h1>\n\n"
+ "#\\b(СЛОВО)\\b#isUu\n\n"
+ "<a>\n"
+ "#\\b(СЛОВО)\\b#isUu\n"
+ "</a>\n\n"
+ "#\\b(СЛОВО)\\b#isUu";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}