use strict;
my $str = 'Entry  Mac                 Vlan INTF PORT MOD MPLS_LABEL ToCpu Drop RefCount
100002  00:00:00:00:00:00 4094    0     0    0        -1  yes   no    2
100004  00 00 1a 0a 84 95    1    1    13    0        -1   no   no    1
100005  a8:97:dc:8c:95:01    3    3     0t   0        -1   no   no    2';
my $regex = qr/((?:[\da-fA-F]{2}[\s:.-]?){6})/mp;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}