// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:[\da-fA-F]{2}[\s:.-]?){6})").unwrap();
let string = "Entry Mac Vlan INTF PORT MOD MPLS_LABEL ToCpu Drop RefCount
100002 00:00:00:00:00:00 4094 0 0 0 -1 yes no 2
100004 00 00 1a 0a 84 95 1 1 13 0 -1 no no 1
100005 a8:97:dc:8c:95:01 3 3 0t 0 -1 no no 2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}