$re = '/((?:[\da-fA-F]{2}[\s:.-]?){6})/m';
$str = 'Entry Mac Vlan INTF PORT MOD MPLS_LABEL ToCpu Drop RefCount
100002 00:00:00:00:00:00 4094 0 0 0 -1 yes no 2
100004 00 00 1a 0a 84 95 1 1 13 0 -1 no no 1
100005 a8:97:dc:8c:95:01 3 3 0t 0 -1 no no 2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);