package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{4})_([^_]+)_([^_]+)_([^_ ]+)(?: \((\S+)(?: (\S+))?\))?$`)
var str = `2022_UT_T1000_100 (Classification1 Classification2)
2022_UT_T1000_100 (Classification1)
2022_UT_T1000_100`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}