re = /^(\d{4})_([^_]+)_([^_]+)_([^_ ]+)(?: \((\S+)(?: (\S+))?\))?$/m
str = '2022_UT_T1000_100 (Classification1 Classification2)
2022_UT_T1000_100 (Classification1)
2022_UT_T1000_100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end