const regex = /^(\d{4})_([^_]+)_([^_]+)_([^_ ]+)(?: \((\S+)(?: (\S+))?\))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{4})_([^_]+)_([^_]+)_([^_ ]+)(?: \\((\\S+)(?: (\\S+))?\\))?$', 'gm')
const str = `2022_UT_T1000_100 (Classification1 Classification2)
2022_UT_T1000_100 (Classification1)
2022_UT_T1000_100`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}