import re
regex = re.compile(r"^(\d{4})_([^_]+)_([^_]+)_([^_ ]+)(?: \((\S+)(?: (\S+))?\))?$", flags=re.MULTILINE)
test_str = ("2022_UT_T1000_100 (Classification1 Classification2)\n"
"2022_UT_T1000_100 (Classification1)\n"
"2022_UT_T1000_100")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")