import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{4})_([^_]+)_([^_]+)_([^_ ]+)(?: \\((\\S+)(?: (\\S+))?\\))?$";
final String string = "2022_UT_T1000_100 (Classification1 Classification2)\n"
+ "2022_UT_T1000_100 (Classification1)\n"
+ "2022_UT_T1000_100";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}