#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-HJ-NP-TV-Z]{2}(00[1-9]|0[1-9]\d|[1-9]\d\d)[A-HJ-NP-TV-Z]{2}"
Local $sString = "AB123HJ" & @CRLF & _
"AB123CD" & @CRLF & _
"AI123CD" & @CRLF & _
"AO123CD" & @CRLF & _
"AU123CD" & @CRLF & _
"AB000CD" & @CRLF & _
"AB001CD" & @CRLF & _
"AB900CD" & @CRLF & _
"AB100CD" & @CRLF & _
"AB010CD" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")