// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-HJ-NP-TV-Z]{2}(00[1-9]|0[1-9]\d|[1-9]\d\d)[A-HJ-NP-TV-Z]{2}").unwrap();
let string = "AB123HJ
AB123CD
AI123CD
AO123CD
AU123CD
AB000CD
AB001CD
AB900CD
AB100CD
AB010CD
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}