import re
regex = re.compile(r"[A-HJ-NP-TV-Z]{2}(00[1-9]|0[1-9]\d|[1-9]\d\d)[A-HJ-NP-TV-Z]{2}", flags=re.MULTILINE)
test_str = ("AB123HJ\n"
"AB123CD\n"
"AI123CD\n"
"AO123CD\n"
"AU123CD\n"
"AB000CD\n"
"AB001CD\n"
"AB900CD\n"
"AB100CD\n"
"AB010CD\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")