using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-HJ-NP-TV-Z]{2}(00[1-9]|0[1-9]\d|[1-9]\d\d)[A-HJ-NP-TV-Z]{2}";
string input = @"AB123HJ
AB123CD
AI123CD
AO123CD
AU123CD
AB000CD
AB001CD
AB900CD
AB100CD
AB010CD
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}