$re = '/[A-HJ-NP-TV-Z]{2}(00[1-9]|0[1-9]\d|[1-9]\d\d)[A-HJ-NP-TV-Z]{2}/m';
$str = 'AB123HJ
AB123CD
AI123CD
AO123CD
AU123CD
AB000CD
AB001CD
AB900CD
AB100CD
AB010CD
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);