using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\u4e00-\u9fa5]{3,}(第一|质量|最)[\u4e00-\u9fa5]{3,}";
string input = @"我国依然是世界上第一人口的国家;中国制造的产品质量依然是....根据数据分析得到的数据结果是最准确的!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}