package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\u4e00-\u9fa5]{3,}(第一|质量|最)[\u4e00-\u9fa5]{3,}`)
var str = `我国依然是世界上第一人口的国家;中国制造的产品质量依然是....根据数据分析得到的数据结果是最准确的!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}