using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-9-_.,:; +<>#´`""?!§°\\*()%$\/&=|Ø]{1,})$|^([0-9.,k]{1,})$|^([0-9 .,|\-]{1,}?°C)*$|^([0-9 .,|\-""\/]{1,}?x?)*$";
string input = @"asss
334445
33sas323
sxs23344s
dd34444
5555003234\_323
233-444
233_444
33-.444
22 2334
33+3-322
-310 23
°10
10%
222/223
334%22
22&222
210=10
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}