const regex = /^([0-9-_.,:; +<>#´`"?!§°\\*()%$\/&=|Ø]{1,})$|^([0-9.,k]{1,})$|^([0-9 .,|\-]{1,}?°C)*$|^([0-9 .,|\-"\/]{1,}?x?)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9-_.,:; +<>#´`"?!§°\\\\*()%$\\\/&=|Ø]{1,})$|^([0-9.,k]{1,})$|^([0-9 .,|\\-]{1,}?°C)*$|^([0-9 .,|\\-"\\\/]{1,}?x?)*$', 'gm')
const str = `asss
334445
33sas323
sxs23344s
dd34444
5555003234\\_323
233-444
233_444
33-.444
22 2334
33+3-322
-310 23
°10
10%
222/223
334%22
22&222
210=10
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}