import Foundation
let pattern = ##"^([0-9-_.,:; +<>#´`"?!§°\\*()%$\/&=|Ø]{1,})$|^([0-9.,k]{1,})$|^([0-9 .,|\-]{1,}?°C)*$|^([0-9 .,|\-"\/]{1,}?x?)*$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
asss
334445
33sas323
sxs23344s
dd34444
5555003234\_323
233-444
233_444
33-.444
22 2334
33+3-322
-310 23
°10
10%
222/223
334%22
22&222
210=10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)