import re
regex = re.compile(r"^([0-9-_.,:; +<>#´`\"?!§°\\*()%$\/&=|Ø]{1,})$|^([0-9.,k]{1,})$|^([0-9 .,|\-]{1,}?°C)*$|^([0-9 .,|\-\"\/]{1,}?x?)*$", flags=re.MULTILINE)
test_str = ("asss\n"
"334445\n"
"33sas323\n"
"sxs23344s\n"
"dd34444\n"
"5555003234\\_323\n"
"233-444\n"
"233_444\n"
"33-.444\n"
"22 2334\n"
"33+3-322\n"
"-310 23\n"
"°10\n"
"10%\n"
"222/223\n"
"334%22\n"
"22&222\n"
"210=10\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")