using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\s*(inverse|reverse|repeat)\s*(?:value\s*=\s*""(\d*)"")?\s*(?:content\s*=\s*"".+?"")\s*>";
string input = @"<inverse content=""HelloWorlD""/>
<reverse content=""helloworld""/>
<reverse content=""helloworld""/>
<repeat value=""2"" content=""helloworld""/>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}