$re = '/<\s*(inverse|reverse|repeat)\s*(?:value\s*=\s*"(\d*)")?\s*(?:content\s*=\s*".+?")\s*>/';
$str = '<inverse content="HelloWorlD"/>
<reverse content="helloworld"/>
<reverse content="helloworld"/>
<repeat value="2" content="helloworld"/>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);