re = /<\s*(inverse|reverse|repeat)\s*(?:value\s*=\s*"(\d*)")?\s*(?:content\s*=\s*".+?")\s*>/
str = '<inverse content="HelloWorlD"/>
<reverse content="helloworld"/>
<reverse content="helloworld"/>
<repeat value="2" content="helloworld"/>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end