#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\D+(\d+)"
Local $sString = ""PlusContent"" & @CRLF & _
""PlusArchieve"" & @CRLF & _
""PlusContent1"" & @CRLF & _
""PlusArchieve1234"" & @CRLF & _
""PlusArchieve123""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")