re = /\D+(\d+)/
str = '"PlusContent"
"PlusArchieve"
"PlusContent1"
"PlusArchieve1234"
"PlusArchieve123"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end