using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w[\s\w]*?\w)\s*kw\s*([\d/*]+)";
string input = @"AL TEST232 KW 12/13/17 TEST kw16TEST123 kw 15*";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}