const regex = new RegExp('(\\w[\\s\\w]*?\\w)\\s*kw\\s*([\\d/*]+)', 'gi')
const str = `AL TEST232 KW 12/13/17 TEST kw16TEST123 kw 15*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}