$re = '~(\w[\s\w]*?\w)\s*kw\s*([\d/*]+)~i';
$str = 'AL TEST232 KW 12/13/17 TEST kw16TEST123 kw 15*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);