// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\w[\s\w]*?\w)\s*kw\s*([\d/*]+)").unwrap();
let string = "AL TEST232 KW 12/13/17 TEST kw16TEST123 kw 15*";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}