re = /(\w[\s\w]*?\w)\s*kw\s*([\d\/*]+)/i
str = 'AL TEST232 KW 12/13/17 TEST kw16TEST123 kw 15*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end