# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(http(s)?:[\/]{2})?([a-z0-9][a-z0-9\-]+.)+([a-z0-9\-])+//g;t' <<< "http://aaa.com.tw
https://aa-a.com.tw
http://aaa.com
https://aaa.com
aaa.com
aaa.com.tw"