// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(http(s)?:[/]{2})?([a-z0-9][a-z0-9\-]+.)+([a-z0-9\-])+").unwrap();
let string = "http://aaa.com.tw
https://aa-a.com.tw
http://aaa.com
https://aaa.com
aaa.com
aaa.com.tw";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}