use strict;
my $str = 'http://aaa.com.tw
https://aa-a.com.tw
http://aaa.com
https://aaa.com
aaa.com
aaa.com.tw';
my $regex = qr/(http(s)?:[/]{2})?([a-z0-9][a-z0-9\-]+.)+([a-z0-9\-])+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";