package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(http(s)?:[/]{2})?([a-z0-9][a-z0-9\-]+.)+([a-z0-9\-])+`)
var str = `http://aaa.com.tw
https://aa-a.com.tw
http://aaa.com
https://aaa.com
aaa.com
aaa.com.tw`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}