#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[\s\S]*?<p>([^<>]*?)<\/p>"
Local $sString = "<h1>I don't want the title</h1>" & @CRLF & _
"<p>This is the text I want</p>" & @CRLF & _
"<p>I don't want this</p>" & @CRLF & _
"<p>I also don't want this</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")