const regex = /^[\s\S]*?<p>([^<>]*?)<\/p>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\s\\S]*?<p>([^<>]*?)<\\\/p>', '')
const str = `<h1>I don't want the title</h1>
<p>This is the text I want</p>
<p>I don't want this</p>
<p>I also don't want this</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}